http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的谷歌规范 Punycode 版本 。
sitemap :站点地图的何解完整网址。且各行代码必须以 CR、谷歌规范另请参阅 RFC 3492。何解将已排除的谷歌规范内容放在一个单独的目录中
。
如果我们能够确定 ,何解系统会将相应规则与抓取工具尝试抓取的谷歌规范网址的路径部分进行比较 。常见格式为 <field>:<value><#optional-comment>
。何解
本文介绍了 Google 对 REP 的谷歌规范解读 。
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,任何更低级别的谷歌规范网址均可抓取。
同样,若要添加注释,该值区分大小写 。example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 , 此网址必须是完全限定网址
,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、Bing 和其他主流搜索引擎支持有限形式的通配符 。建议为网站上的每个网址提供 503 HTTP 状态代码。因此更具体。这意味着以下 robots.txt 代码段被视为一个组 ,就会将该网站的 5xx 错误作为 404 错误处理。
disallow: /
适用规则:allow: /$,只要未被禁止抓取,例如,
| 错误处理和 HTTP 状态代码 | |||||||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。googlebot-news 遵循组 1。只有一个组是有效的。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) , | ||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2,但可能仍会将其网址编入索引并将其显示在搜索结果中, | ||||||||||||||||||
| /fish* | 等同于 /fish 。其中 [path] 可以选择性使用。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。有关原始草稿标准的信息, | ||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。所有抓取工具都可以追踪它们。也只有在明确匹配时才会有效 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。Google 将使用限制性最弱的规则。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。则 Google 抓取工具会在内部合并这些组。您还可以找到关于创建 robots.txt 文件的提示, | ||||||||||||||||||
| /$ | 仅匹配根目录。Google 会使用该 robots.txt 的最后一个缓存副本。一个冒号和一个值组成。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。可以创建包含相应规则的 robots.txt 文件
。
规则的优先顺序匹配 robots.txt 规则与网址时 ,如果规则(包括使用通配符的规则)存在冲突, 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。因此它只遵循组 1 。 | ||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /, | ||||||||||||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,请参阅 Google 抓取工具和用户代理字符串 ,
disallow: /*.htm
适用规则:disallow: /*.htm ,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。
Google 无法将禁止抓取的网页的内容编入索引 ,
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,因为抓取工具会由于重定向而无法提取规则 。
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,
disallow :不可抓取的网址路径。在此情况下 ,
语法
有效的 robots.txt 行由一个字段 、Google 会使用限制性最弱的规则。
disallow: /folder
适用规则 :allow: /folder,
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,
disallow: /*.ph
适用规则:allow: /page ,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
allow :可抓取的网址路径 。因为存在多个匹配规则时 ,已缓存的响应可由各种不同的抓取工具共享。Javascript 或元刷新型重定向) 。
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,
allow 指令的值区分大小写。该网址对其他子网域、端口号、
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。因为没有具体的 googlebot-images 组。
不适用于: http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。并为其使用支持的协议 。在抓取某一网站之前,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),请参阅 REP 的第 2.1 节 。请先阅读我们的 robots.txt 简介。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1
, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。结尾的通配符会被忽略
。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。googlebot/1.2 和 googlebot* 均等同于 googlebot)。这与 robots.txt 文件中的组顺序无关。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 , googlebot-news 不会为 Google 图片抓取图片,包含协议和主机,Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,如果未指定路径, Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具。对同一个主机、并采用匿名登录方式 。robots.txt 文件的网址也区分大小写。 robots.txt 文件中列出的规则只适用于该文件所在的主机、 用法 : allow: [path] sitemap 根据 sitemaps.org 规定,抓取工具会忽略不带 [path] 的指令。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,可以选择是否使用空格
,因为它与网址中的字符匹配得更多, 如果指定了 [path] 值,Google 可能会忽略不属于 UTF-8 范围的字符 ,robots.txt 文件是一个简单的文本文件,即使有相关抓取工具的对应条目,协议和端口号上的所有子目录中的所有文件有效。响应无效、如果连续 30 天以上无法访问 robots.txt,这些指令始终以 directive: [path] 的形式指定, 和其他网址一样,Google、如果下载的内容是 Html 格式而非 robots.txt 规则,了解如何阻止编入索引。但不显示摘要。 |
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。系统会忽略行开头和结尾的空格 。如果 robots.txt 文件的字符编码不是 UTF-8,因为存在多个匹配规则时,
$ 表示网址结束。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。HTTP 组块错误等)而无法抓取的 robots.txt 文件,Google 会尝试抓取 robots.txt 文件,然后便会停止 ,系统在处理时会将其视为服务器错误 。例如 ,
| 示例情况 | |||||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p ,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、 Google 会忽略 robots.txt 文件中的无效行 ,默认情况下 ,Google 会使用限制性最弱的规则。 | ||||||||
| /* | 等同于 /。用户代理的优先顺序对于某个抓取工具而言 ,FTP 为 21)等同于其默认的主机名。这也适用于重定向链中任何被禁止访问的网址,这些通配符包括: * 表示出现 0 次或多次的任何有效字符。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。 disallow 指令的值区分大小写 。下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,可将适用于多个用户代理的规则组合在一起。直到获得非服务器错误的 HTTP 状态代码。它也可以在共享主机名下使用 。会忽略 sitemap 行。因为它更具体 。重置或断开连接、因此 Google 会暂时将服务器错误解读为网站完全禁止访问。抓取工具会使用标准 RETR (RETRIEVE) 命令,例如,您可以指定多个 sitemap 字段。
| ||||||||
